Request for Assistance with CTA GitLab SSO Error

I want to contribute to CTA, so I visited their GitLab code repository. However, I encountered an error when trying to use my email address for Single Sign-On (SSO), even after attempting to use my GitHub account. Would anyone be able to assist me with this issue? I apologize for asking an irrelevant question here.


The CTA GitLab repo is hosted at CERN. The repo has read access open to anyone to access the source code, but developer privileges require a CERN primary account. A CERN lightweight account is not sufficient.

We do grant access to a number of external contributors; in general these are people working in scientific research institutes which have a tape installation where CTA is installed (or is planned to be installed). As these collaborations require a CERN primary account, it is necessary to have a cooperation agreement between the institute and CERN.

What kind of contribution did you have in mind?



Hello Michael,

I was hoping you could help clarify something for me. I’m trying to learn CTA and was thinking about contributing to some open issues and optimizations in this repository. However, I’m not sure if I need to install tape where CTA is installed in order to work with this repository. Could you please confirm if this is necessary?

Additionally, I was considering working on the following todo item: objectstore/Helpers.cpp · main · cta / CTA · GitLab.

Thank you.

To start, see if you can get a working CTA installation, following the Deployment Guide. Start with the “easy” installation using containers. Once that is working, try to set up everything manually. This will help you to understand the different CTA components and how they interact.

The dev installation includes mhVTL, the virtual tape library, which takes the place of a physical library for development and testing.

The TODO item you mention is not a priority, as the objectstore is sufficiently performant for now, and we plan to replace the SchedulerDB with a database implementation. (This will be discussed in the CTA Roadmap talk at next week’s EOS Workshop, which you are welcome to attend).

If you would like to contribute something, how about starting with this issue? Unit test for what happens during an archive mount if the tape becomes full (#22) · Issues · cta / CTA · GitLab

Thank you, Michael. I will attempt to set up CTA on my local machine and keep you updated on my progress. By the way, I registered for the workshop last week.

Hello @mdavis,

I tried following the CTA docker setup mentioned in this GitLab repository:

However, when I ran the command docker build --force-rm -t ctafrontend-cc7 cc7/, I received an error message stating that the Dockerfile could not be read. After checking, I found that there was no Dockerfile in the cc7 folder. Instead, I found Dockerfiles in a subfolder named cc7. I attempted to run those Dockerfiles, but they did not work.

Hello Rajiv,

I think the document you are looking at is outdated.
Our installation procedure is a bit complex, but if you follow these instructions it should be possible to setup CTA from scratch: A CTA instance built from source in a standalone VM - EOSCTA Docs
These are the same instructions we follow here to setup a machine for development, so let us know in case you face any issues. The starting point should be a standalone CentOS 7 VM.

Best regards,

Hi @afonso,

I attempted using the A CTA instance built from source in a standalone VM - EOSCTA Docs method. However, I encountered an error after running the following command:

➜ buildtree_runner git:(main) ./
Creating the docker image...
./ line 18: cd: /Users/rajiv/CTA: No such file or directory
➜ buildtree_runner git:(main) pwd

I noticed that the file is present when I ran the following command:

➜  buildtree_runner git:(main) ls
➜  buildtree_runner git:(main)

The script expects the CTA repo to be /Users/rajiv/CTA but you have cloned it under /Users/rajiv/Desktop/CTA.