When will cta-public-repo be public?

Dear CTA Team,

I’m Jordi Casals, working at PIC and one of the members testing CTA.
We wanted to ask you about the distribution of public binary rpms.
We have seen in this issue (Public binary rpm distribution. (#15) · Issues · cta / CTA · GitLab) that a link to the cta-public-repo was published a week ago (Index of /cta-5/el-7/cta/x86_64).
However, it seems that we do not have access to the content of this repository as we are an external center. Is this intended? Or should we be able to have access already?
We have been trying (with the help of DESY) to test CTA with dCache (initially with the modified code they provided us, now with cta-grpc rpm), and along the versions we have tested we have had some problems. Last version we have was downloaded from one commit (the last at that time) artifacts, but we don’t see this as an option for the future.
If the distribution is not ready yet, could you provide an approximate release date in which we can access to it? Also, will this public repo provide the necessary dependencies too? We had some trouble finding, compiling and installing some of them in our own.
It would be great for us if we could use this repository to discard that we have any problems with our manual builds, but also to use it with puppet, not having to rely on downloading packages, installing manually and then do the same thing in other servers.

Thank you so much,


Hello Jordi,

Welcome to the CTA community!

The work on publishing the public release is still in progress. We expect to finalize it during next two weeks. We will prepare the documentation page that will describe the required steps to install RPMs and dependencies.

I’ll let you know when everything will be ready.


Hello CTA team,

Just checking how is this going. We have seen a lot of activity in the gitlab issue related to that, it looks that everything is ready but the repos are still not accessible from the outside of CERN.

Any idea when they are going to be?


Dear @jcasals ,
could you please give it another try? We made adjustments to the public repo yesterday around noon which should have resolved the remaining access issue.
We just tried the install using the rpms from https://cta-public-repo.web.cern.ch/ in a container outside of the CERN network, and it appears to have worked just fine.

Dear @rbachman,

I tried it now and it it accessible! I tried it yesterday and it wasn’t yet, so great news!
We’ll try to install everything from here, hope we don’t have too much trouble with dependencies outside cta-*.

Step by step, thanks!

Dear CTA team,

This message is just to let you know that we have been installing (re-installing) our servers using this public repository (and tied to the installation of cta-release package to use versionlock provided by it) and everything is able to be installed without problems.

We have some issues related to transfers, etc, but we’ll update you in other topics.